[IOT-2786] ignore wrong ACE version in ACL 21/22721/2
authorNathan Heldt-Sheller <nathan.heldt-sheller@intel.com>
Fri, 6 Oct 2017 20:59:16 +0000 (13:59 -0700)
committerNathan Heldt-Sheller <nathan.heldt-sheller@intel.com>
Tue, 17 Oct 2017 16:30:26 +0000 (16:30 +0000)
commitfcab5a4ccc2834e19b2b3370a519b48e10bd5ed0
tree4ced9501c78fda287a4f895cef2b6573a048a697
parenteb9e0d4873788710fb0b2ebd964b28ca532acb00
[IOT-2786] ignore wrong ACE version in ACL

The current parsing code will accept a v1 ACE in a V2 /acl payload
and vice versa.  It should at least ignore and skip the wrong-version
ACE.

Change-Id: I9cb3fc84671afe25a730484e4fb2904a0d3c5c95
Signed-off-by: Nathan Heldt-Sheller <nathan.heldt-sheller@intel.com>
resource/csdk/security/src/aclresource.c