bridging: Add explicit dependency to libmpm 11/23411/10
authorPhilippe Coval <philippe.coval@osg.samsung.com>
Wed, 22 Nov 2017 17:16:45 +0000 (18:16 +0100)
committerTodd Malsbary <todd.malsbary@intel.com>
Wed, 17 Jan 2018 20:24:53 +0000 (20:24 +0000)
commitc6916eea3d199b5700dd70b806d94c9db2df1ddf
treec1860d0e00340035796fe46b72e11c12cde3e19e
parente0d9f4464c5c59c1d4d49d8a5f7d3a12b47d2c1d
bridging: Add explicit dependency to libmpm

While working on "scons install", static lib were not resolved.
So I found this could be changed separately

Observed issue was:

 Linking shared .../libhueplugin.so
 g++: error: .../out/.../libmpmcommon.a: No such file or directory
 scons: *** [out/.../libhueplugin.so] Error 1

This was needed for ARTIK7 on fedora-24

Bug: https://jira.iotivity.org/browse/IOT-524
Change-Id: Ibadd174bd84bcaf48d972fdb3071ba3b03ff1373
Origin: https://github.com/TizenTeam/iotivity/tree/sandbox/pcoval/on/master/fedora
Forwarded: https://gerrit.iotivity.org/gerrit/#/c/23409
Signed-off-by: Philippe Coval <philippe.coval@osg.samsung.com>
bridging/plugins/hue_plugin/SConscript
bridging/plugins/lifx_plugin/SConscript
bridging/plugins/lyric_plugin/SConscript
bridging/plugins/nest_plugin/SConscript